[PJUG Javamail] Java Web Start on my Mac

Ted Kubaska tedkubaska at comcast.net
Wed Feb 25 01:53:47 EST 2009


Thanks, Jon.  I did discover that I can run Java Web Start examples  
from a different site successfully ... namely http://java.sun.com/javase/technologies/desktop/javawebstart/demos.html

There must be something screwy with that treelight site.  Would be  
nice to know what it is ... if it is some config on my part or not.
-ted

On Feb 24, 2009, at 12:13 PM, Jon Batcheller wrote:

> Send me the JNLP - and turn on your console with tracing
> and debugging for more info.  Be sure security all checked.
>
> Applications/Utilities/Java/Java Preferences
>
>
>
> On Tue, Feb 24, 2009 at 11:57 AM, Ted Kubaska  
> <tedkubaska at comcast.net> wrote:
>> I'm having trouble getting Java Web Start working on my Mac.  (Jon,
>> you've been running Web Start on your Mac forever!) Java itself works
>> fine. Eclipse with Java works fine. Here' my version.
>>
>> newtricks:~ ted$ java -version
>> java version "1.6.0_07"
>> Java(TM) SE Runtime Environment (build 1.6.0_07-b06-153)
>> Java HotSpot(TM) 64-Bit Server VM (build 1.6.0_07-b06-57, mixed mode)
>> newtricks:~ ted$
>>
>> I think my issues are very simple, but I'm really kind of stuck.
>>
>> I'm just trying to run a demo. A hello world demo ... just to see how
>> it works.
>> I went to  http://www.treelight.com/software/JavaWebStart/index.html
>> and clicked HelloWorld.
>>
>> I get a screen that says
>> <quote>
>> HelloWorld Demo
>> Click here to launch the application.
>> (It will be downloaded if it isn't already installed.)
>> </quote>
>>
>> I click on "Click here." I get a screen that asks if I want to open
>> with Java Web Start. I click on OK. I then get a screen that says
>> "Java Web Start Starting ..." and then I get a screen after a few
>> seconds that says "Unable to launch application" I click on Details,
>> then Exception and see
>>
>> <quote>
>> java.lang.NoClassDefFoundError: DebuggerRT
>>   at hello.HelloWorld.<cinit>(HelloWorld.java)
>>   at sun.reflect ......
>> ....
>> Caused by java.lang,.ClassNoTFoundException: DebuggerRT
>> </quote>
>>
>> _______________________________________________
>> Web Site - http://www.pjug.org/
>> Javamail mailing list
>> Javamail at pjug.org
>> http://www.pjug.org/mailman/listinfo/javamail
>>
> _______________________________________________
> Web Site - http://www.pjug.org/
> Javamail mailing list
> Javamail at pjug.org
> http://www.pjug.org/mailman/listinfo/javamail

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.pjug.org/pipermail/javamail/attachments/20090224/d674bd19/attachment.html 


More information about the Javamail mailing list